Current time: 22.08.2018, 07:43 Hello There, Guest! (LoginRegister)
Language: english | russian  

Poll: Нужна ли в Эре поддержка Windows XP?
Нужна
Не нужна
Сложно сказать
[Show Results]
Note: This is a public poll, other users will be able to see what you voted for.
Post Reply 
Threaded Mode | Linear Mode
Нужна ли в Эре поддержка Windows XP?
Author Message
Berserker Offline
Administrators

Posts: 10554
Post: #1

Голосуем. В XP нет части интересных системных функций, её не поддерживает PHP 5.5+, на неё не идут обновления и практически никто на ней не тестирует.
/Но ExaGear-подобным симуляторам от этого только плюс.


Скачать Герои 3 Эра и всё, что с ней связано
28.11.2017 21:39
Find all posts by this user Quote this message in a reply
MOP Offline

Posts: 1320
Post: #2

Сложный вопрос. Я за движение вперёд и прекращение поддержки всякого старья во избежание лишних трудовых затрат, но у меня до сих пор не получилось продержаться даже на Семёрке более двух недель. Удовольствие от удобства и скорости быстро оборачивалось внезапными вылетами и экранами смерти. То ли сборка плохая, то ли вирус... Короче, вернулся на XP и не парюсь.
Кстати, о старье. Исходя из баг-репортов к MoP, сделал вывод, что даже SSE2 не у всех поддерживается. Вот вам и прогресс.


Я на Лит-Нете
28.11.2017 22:14
Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 10554
Post: #3

MOP, сборки ovgorsky ни разу не подводили. Синих экранов не видел на Win 7 никогда )

Quote:Кстати, о старье. Исходя из баг-репортов к MoP, сделал вывод, что даже SSE2 не у всех поддерживается. Вот вам и прогресс.
Да, помню в журналах изменений MoP. Старыми машинками тоже пользуются.


Скачать Герои 3 Эра и всё, что с ней связано
28.11.2017 22:31
Find all posts by this user Quote this message in a reply
Algor Offline
Administrators

Posts: 2569
Post: #4

Berserker, убирать поддержку XP крайне нежелательно. Имхо, это может быть принято только если на другой стороне весов что-то О-о-очень вкусное и совершенно никак не совместимое со старой осью. Такое есть (хотя бы в планах)?

Сам я давно на семерке, но старенький ноут ее практически не тянет, а герои там идут вполне себе бодро.


28.11.2017 23:09
Visit this user's website Find all posts by this user Quote this message in a reply
gamecreator Offline
Administrators

Posts: 7146
Post: #5

У меня пока ХР, поэтому поддержка нужна.

Ну а если серьёзно, то Algor всё верно сказал.


When all gods have burnt to ashes in eternity of sorrow,
Demons gonna tear your soul because there is no tomorrow.
29.11.2017 00:04
Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 10554
Post: #6

Хорошо. Если копирасты нагнут мир, будет играть на ReactOS. Тогда только утилиты могут требовать Windows-7. Весь основной функционал должен работать на XP.


Скачать Герои 3 Эра и всё, что с ней связано
29.11.2017 00:51
Find all posts by this user Quote this message in a reply
XEPOMAHT Offline

Posts: 85
Post: #7

Например в последней версии MMArchive зачем-то кастрировали поддержку виндос 5.хх, соответственно, приходится пользоваться устаревшей версией. На 100% то же самое будет с ERA, т.к. запуск на моём ПК виндовоза 6.хх и выше сродни полёту пепелаца в космос без гравицапы (бета-версия виндос вислы устанавливается, но сыпет ошибками с синим экраном смерти, разогревая ЦП и планки с ОЗУ до критических температур, финалка вислы не устанавливается вообще, с виндос 7 реакция аналогичная - тамошний виндовозный установщик вешается напрочь). Уже лет 10 как установлен Windows 2003 - тянет всё что необходимо, работает быстро и эффективно, а главное не греется совсем.

ERA должна двигаться вперёд, но наверное не стоит повышать системные требования без очень сильной необходимости со стороны разработчика (HD мод вроде без этого прекрасно живёт).
29.11.2017 00:59
Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 10554
Post: #8

Поддерживаю. Сам долго был на такой машинке, пока не собрал первый комп с нуля уже серьёзной конфигурации и не забыл старые проблемы как страшный сон.


Скачать Герои 3 Эра и всё, что с ней связано
29.11.2017 03:07
Find all posts by this user Quote this message in a reply
fireman Offline
Forum Moderators

Posts: 1426
Post: #9

А чего мы теряем, если остаётся поддержка XP?


Новости по WoG 3.59, ХотА и другим модам.
29.11.2017 22:45
Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 10554
Post: #10

Я сейчас много пишу на PHP 7+, он не поддерживается. И ещё пара системных API, которые для работы не критичны. Если подключать внешние DLL, то нужно убеждаться, что на XP пойдут. В целом вполне реально сохранить поддержку.


Скачать Герои 3 Эра и всё, что с ней связано
29.11.2017 23:19
Find all posts by this user Quote this message in a reply
baratorch Offline

Posts: 168
Post: #11

Считаю, что если ты можешь маленькими затратами расширить свою аудиторию, то почему бы это не сделать.
Я с ХД специально имею парк операционок на Virtual Box'е.
И запариваюсь даже с поддержкой Wine и ReactOS, а с ними бывают специфические проблемы.
Так же как и с XP бывают специфические проблемы.
Сам пользуюсь в основном семеркой (+ 10ка на планшете и Server 2016 на сервере хоты).

В лобби сервере хоты у меня и ОС ниже 10ки не поддерживается и AVX2 инструкции используются,
А вот прикручивать SSE инструкции к клиенту ХД я смысла не вижу, точнее видел бы в опциональном модуле графики,
но быстрее моих MMX решений ничего сделать не получилось. MMX используется так же только в опциональных модулях графики.

Необходимости SSE2 в МОП я совершенно не вижу, они там есть скорее всего из-за любви к кодингу ими и из-за нежелания выносить свой код за пределы оригинального.
30.11.2017 03:34
Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 10554
Post: #12

Quote:В лобби сервере хоты у меня и ОС ниже 10ки не поддерживается
Вот это уже довольно жёсткое ограничение. Даже топ-игры семёрку не сбрасывают со счетов. Есть причины? ))


Скачать Герои 3 Эра и всё, что с ней связано
30.11.2017 04:38
Find all posts by this user Quote this message in a reply
baratorch Offline

Posts: 168
Post: #13

Ну потому что лобби-сервер выполняется на единственной, подконтрольной мне машине, которая удовлетворяет требованиям.
Но если вдруг в будущем придется пересесть на машину с ограничениями, перекомпилировать лобби-сервер не будет проблемой.
30.11.2017 05:05
Find all posts by this user Quote this message in a reply
MOP Offline

Posts: 1320
Post: #14

(30.11.2017 03:34)baratorch Wrote:  Необходимости SSE2 в МОП я совершенно не вижу, они там есть скорее всего из-за любви к кодингу ими и из-за нежелания выносить свой код за пределы оригинального.
Их там и нет. Есть лишь одна опция, где я последовательно использовал пару команд сначала SSE4.1, потом SSE3, затем SSE2 - снижая требования каждый раз, как получал баг-репорт. Это было исследование возможностей компьютеров пользователей из чистого любопытства. Странно представить любовь к кодингу ненужными для этого командами с длинными опкодами.


Я на Лит-Нете
(This post was last modified: 30.11.2017 06:24 by MOP.)
30.11.2017 06:24
Find all posts by this user Quote this message in a reply
baratorch Offline

Posts: 168
Post: #15

Quote:Это было исследование возможностей компьютеров пользователей из чистого любопытства.
Понятно. И, sse2 так и не пришлось убрать?
30.11.2017 12:36
Find all posts by this user Quote this message in a reply
« Next Oldest | Next Newest »
Post Reply 


Forum Jump:

Powered by MyBB Copyright © 2002-2018 MyBB Group