Current time: 29.11.2022, 21:02 Hello There, Guest! (LoginRegister)
Language: english | russian  

Post Reply 
Threaded Mode | Linear Mode
ERA II
» WoG Era 2: Русская и Английская версии
Author Message
Valery Offline

Posts: 2132
Post: #4651

More than half of Era 2 mods authors are gone and inactive. If you break compatibility, is like throwing all their work as garbage. Sagamosa, Jim Vogan and so many custom maps, that's part of Era history and success.

As for me, I will not update my scripts, 10 years of work was enough. If Era 2 is no longer compatible and no wish to keep it compatible, thats fine, I shut down my google drive, remove mods from maps4heroes and thats it, move to something else.

Personally I don't see why Era 2 and Era 3 can't be separated, one for legacy, the next for progress. But tell me now what the intentions are, so I don't waste my time answering angry players emails that this or that mod no longer work.


Era mods and utilities
17.06.2020 22:36
Find all posts by this user Quote this message in a reply
Bes Offline

Posts: 5397
Post: #4652

Algor, +1
P.S. просто всё упирается в многолетнее понимание WoG, когда он всегда был самодостаточным. А сейчас его раскололи на отдельные части, согласно принятой автором платформы файловой концепции, но "низы" пока это не осознали как преимущество.
единственная проблема - недостаточная информированность рядовых моддеров/фанатов в структурных изменениях (лога истории ERA как видишь, Berserker, оказывается недостаточным... нужна активная пропаганда на HC этих изменений)
17.06.2020 23:25
Visit this user's website Find all posts by this user Quote this message in a reply
Bes Offline

Posts: 5397
Post: #4653

Valery, понимаю твоё негодование, особенно когда такая армия фанатов ругается на баги при игре в твои рабочие моды.
Не стоит рубить с плеча, имхо, достаточно указать требования к работоспособности модов. Если игрок их не соблюдает - это НЕ ТВОЯ проблема, а его. Пусть ищет ответы на форуме.

P.S. и да, поднятие требований работоспособности твоих модов до обязательной установки их на платформу ERA2.9.x является сугубо твоей прерогативой. А это конечно требует определённых затрат сил, дабы всё адаптировать. Опять же, тебе решать надо тебе это или нет.
(This post was last modified: 17.06.2020 23:34 by Bes.)
17.06.2020 23:31
Visit this user's website Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 15867
Post: #4654

igrik, я пропал на два года и скрипты 3.58 остались старыми и забагованными? Ни в коем случае нельзя на одном человеке замыкать абсолютно не связанные друг с другом задачи.

Valery, emotions are not our allies, my friend. Let me explain my position, because nothing crucial happened at all.

1) ERA ≠ Era installer package. Package is subject to changes. Everyone can make his/her own package. For instance, I installed huge 20 GB package of Skyrim with tons of mods preinstalled. They are not compatible with many other mods like your new mod, but I don't care, because absolute compatibility is not possible at all. I play mister X's package. Package is not the same as script engine of specific version, system libraries, etc. This is key point. One author can make changes in script engine, but other things are subject to change/recombine/customize.

2) If your mod depends on WoG 3.58f scripts, you either require WoG 3.58 or old Era package with 3.58 scripts frozen.
Thus, if ERA 2.46 satisfied all your needs and is well tested/has known bugs, it's ok. Specify it's as a requirement. Provide your own stable link to it. You can even modify package in WinRar and call it Heroes 3 Valery's Edition.
Create FAQ topic with the first answer: download and use this package (LINK) to play the mods. That's all.

There is no single holy link, which everyone uses. I will host 2.46 version without a problem and recommend you to do the same.
to some version, which allow to play any old/new/changed scripts/mods/packages.
And you know, igrik/Algor changed a lot in 3.58 scripts, thus my old Phoenix Mod may have issues with it. Changed scripts use new syntax/commands. I cannot just include their files with hundreds of edits and say: "They work the same as old 3.58 scripts". Even more, after some bugs were fixed (like possibility to reuse Emerald tower each month), we've got aggressive demands to restore old behavior! Some people used to play with bugs and consider them a feature! It's not a task for me to handle all of this. So let player install core and installs those scripts/mods like WoG Revised, that he wants.

Let modder write about his dependencies or specify link to package to be used.

I hope to port all your mods some day (carefully downloaded all of them) and provide possible semi-automatical translation, because they were written in English without json file usage and separate translation without code editing is hard.


Скачать Герои 3 Эра и всё, что с ней связано / ERA 2.46f для старых модов
Поддержать проект
17.06.2020 23:45
Find all posts by this user Quote this message in a reply
Bes Offline

Posts: 5397
Post: #4655

Berserker, единственным правильным для тебя ходом, в сегодняшних движениях era2/3 это размещать вместе с сылкой на релиз ещё и ссылку на WoG Scripts
дабы люди сразу качали два архива, а не упирались в ошибки и искали их причину где-то в сети
думаю это будет практично и просто
17.06.2020 23:52
Visit this user's website Find all posts by this user Quote this message in a reply
Valery Offline

Posts: 2132
Post: #4656

I still don't get why you don't let 2.9.15 with wog scripts in, so it provides 100% compatibility with all Era 2 mods, without exception. The only few actions to make everything perfect will be me removing era hooker and pandora api from my packages. Then all mods will be compatible with Era 2.

Then comes Era 3, another thing. I understand platforms evolve and I have no argument against. This is why its called Era 3 and not 2. So let me know your decision, so I can take mine.


Era mods and utilities
18.06.2020 00:03
Find all posts by this user Quote this message in a reply
Bes Offline

Posts: 5397
Post: #4657

Valery, была тактическая ошибка Berserker'а, когда он после ERA2,46 не сменил глвный индекс версии... отсуюда и все эти коллизии.
Всё что после 2,46 уже другая платформа.
от 2,47/2,55 до 2,9,15 - это должна была быть ERA3.0.хх
а нынешняя ERA3 - это должна была быть ERA3.5.x
Dry
но решения назад не вернуть, так что имеем вот такие противоречия понимания одних о изменениях в концепции и автора
18.06.2020 00:14
Visit this user's website Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 15867
Post: #4658

Valery, because of many things:
1) If I do so, WoG Scripts development will be frozen. Currently it's active. People release updates and I don't handle bug reports and everything else. I just physically cannot handle all that 18 years old code. So I don't provide updates, people are complaining. I extracted mod, now it has updates. Everything player needs is two mods installation (core + specific scripts package), but it's not a hard task for PC user.

2) Current WoG Scripts by Algor/igrik and other guys mod differs greatly in sources from original 3.58f. They use new commands, change behavior, probably introduce new bugs. To play Phoenix Mod I would use older WoG Scripts mod (hosted on hmm35.ru), because I included only most obvious fixes in it from Algors's Era Scripts Rus.

It's my task to remove 3.58 dependencies from Phoenix Mod or demand exactly this/that mod to be used.
I think we will port your mods (and many of them work on Era 3 with small corrections), but it's much easier for your to

A) Host link to ERA 2.46.exe and specify, that all it's scripts/contents is a required dependency.
B) Optionally continue testings ERA 2.9.14 + WoG Scripts by (em, igrik & Algor, most modern?). Then most players will know, that both 2.46 and 2.9.14 + WoG Scripts will fit their needs.

But please, don't delete anything. Your works are masterpieces and Heroes 3 heritage.

Bes, изменения в движке не было кардинальными. Адаптация скриптов была минимальной. Мажорную версию просто так не увеличивают. От скриптов WoG 3.58 я хотел избавиться очень давно, изначально выступая за максимальную модульность.


Скачать Герои 3 Эра и всё, что с ней связано / ERA 2.46f для старых модов
Поддержать проект
18.06.2020 00:22
Find all posts by this user Quote this message in a reply
Valery Offline

Posts: 2132
Post: #4659

Look, there is no emotion. I just think this is beyond me and have no desire of participating any longer in. I see emails from players coming daily and asking me why this doesn't work. That annoys me because I produced tested work time ago and now I don't feel like having the desire to debug, ask for solutions or test or whatever. So its ok, good luck with Era 3, this is great asset for Homm3.


Era mods and utilities
18.06.2020 00:49
Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 15867
Post: #4660

Valery, could you update your maps4heroes posts with 2.46 installer link then? Preferebly on Google Drive you own, because links die.
It will be necessary anyway, because soon most of new packages and assemblies will be based on Era 3. Porting/fixing older mods is a task (like I did with 3.58 mods), but it's our task. Feel free to create new works for different games we will always appreciate.


Скачать Герои 3 Эра и всё, что с ней связано / ERA 2.46f для старых модов
Поддержать проект
18.06.2020 00:51
Find all posts by this user Quote this message in a reply
PerryR Offline

Posts: 434
Post: #4661

Apps on my mobile phone stop working when my operating system gets updated. If nobody takes care of these programs they start to die. Not saying that it's good, but that's just how it is. You cannot take all responsibility away from the user. If they are able to update their Heroes/ERA to use the newest mods they should also be able to inform themselves about possible conflicts or ways to solve it. If people would post more of these conflicts on heroes community or on heroes3.5 we could take care of, but I don't see many complaints.
Idea: forward these issues to us on Discord, that will probably speed up the process.

Second: In a year from now. People will be using ERA 3. And they will still download these mods and complain.
Conclusion: If the old mods don't get updated the situation will not change.
Third: I think the fixing of these mods is not so hard. Mostly it will be a little correction and everything will work.

If we start the process of fixing now or on 6 months doesn't matter. In my opinion, these fixes should be made on the base of ERA 3, everything else will just delay the core problem. Starting to deliver ERA 2.46 to play older mods might be a temporary solution, but it will just get worse in the future.

We can create a forum entry where mods are listed that lost compatibility due to the new ERA, together with the specific reports. The list will not be endless. Everybody who is in the mood can work on it. After some time we should be able the have all mods that Sal has on its google drive link are updated, or at least the ones which are worth it.
(This post was last modified: 18.06.2020 02:04 by PerryR.)
18.06.2020 01:23
Find all posts by this user Quote this message in a reply
Valery Offline

Posts: 2132
Post: #4662

As I said I fully understand this, but I still think it should remain individual choice to follow those changes or not.

The problem is that I did a few dozens of mods, some with era.hooker, with pandora api, then Era later versions requested those to be removed, then I did so then re-uploaded them. Then now the last Era does not work with my mods - it clearly needs hours of testing, so I must go back to 2.46 but before I have to reinstall era.hooker and I don't remember which mod had them. Then, as you said, people will keep installing Era 3 or Era 7, believing it will work with anything done before, then will spam me and others with angry comments.

See? I am done with this shit. No patience and motivation to do so. I am no longer interested into Heroes, so let's close the chapter and don't worry about me.


Era mods and utilities
(This post was last modified: 18.06.2020 11:27 by Valery.)
18.06.2020 11:18
Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 15867
Post: #4663

Valery, ok. We can edit 2.46 package for your mods and include ERM Hooker and Pandora/Seer huts plugins right in the package.
The only thing we need is some old mod with old ERM hooker and gamecreator's libraries included. I'll search for them.

And Val, I hope will fix all minor issues with mods, just don't do any destructive actions )


Скачать Герои 3 Эра и всё, что с ней связано / ERA 2.46f для старых модов
Поддержать проект
18.06.2020 16:23
Find all posts by this user Quote this message in a reply
Algor Away
Administrators

Posts: 3821
Post: #4664

Berserker, у меня в архивах вроде валялся 2,46 если нужно. Во всяком случае, в установленном виде есть.


BattleHeroes Rus/Eng | ERA scripts (+ReMagic) Rus/Eng
18.06.2020 16:40
Visit this user's website Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 15867
Post: #4665

Algor, у меня тоже есть. Нужны ERM Hooker 1 и оригинальные плагины от gamecreator.
Валера уже успел удалить файлы на Гугл диске Sorry


Скачать Герои 3 Эра и всё, что с ней связано / ERA 2.46f для старых модов
Поддержать проект
18.06.2020 16:41
Find all posts by this user Quote this message in a reply
« Next Oldest | Next Newest »
Post Reply 


Forum Jump:

Powered by MyBB Copyright © 2002-2022 MyBB Group