Current time: 17.06.2024, 17:09 Hello There, Guest! (LoginRegister)
Language: english | russian  

Post Reply 
Threaded Mode | Linear Mode
ERA II
» WoG Era 2: Русская и Английская версии
Author Message
Valery Offline

Posts: 2196
Post: #4636

is the "latest era" link? Because I see no 2.9.14 but 2.9.9 as last
17.06.2020 00:59
Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 16528
Post: #4637

Scroll upper, please. 2.9.14 is above 2.9.9, because of sorting.
https://yadi.sk/d/Bhg4CGTf3PXi3k/Release...2.9.14.exe


Скачать Герои 3 Эра и всё, что с ней связано / ERA 2.46f для старых модов
Поддержать проект
17.06.2020 01:07
Find all posts by this user Quote this message in a reply
Valery Offline

Posts: 2196
Post: #4638

Got it thanks
17.06.2020 01:10
Find all posts by this user Quote this message in a reply
Valery Offline

Posts: 2196
Post: #4639

Image: z9ldXR.jpg

I started a game on tew3 with all interface mods enabled. The errors come from only 2 mods, advanced estates and Tew3. tew3 uses a dat file so that enables certains erm regular scripts. Advanced estates modifies TOBYN'S SCRIPTS (script64.erm) (2004 September 19)
Other interface mods work okay. I got an error about seer huts that pandora api is not supported (it is in the mod), probably you put it into Era now? So I removed the plugin from mod then everything went okay, seer huts works 100%

tew3
https://drive.google.com/file/d/1HIySjcv...sp=sharing

advanced estates
https://drive.google.com/file/d/1yzpGVh2...sp=sharing

Tried start on tew4 etc, is Ok. So its only about using a dat file. However I am confused as people using 2.9.13 were able to start the map, so are the changes to 9.14 so radical or something wrong on my system?
(This post was last modified: 17.06.2020 11:11 by Valery.)
17.06.2020 10:13
Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 16528
Post: #4640

Valery, the simpliest answer is that $spell$ macro is not found. Era 2.9.14 does not provide WoG Scripts anymore. It's not my dependence. igrik & community work on it from now.
Thus you have no !?TM2 timer preset and no $spell$ macro defined, but you still have a hidden dependency on old WoG Scripts mod.
http://mods.hmm35.ru/WoG%20Scripts.exe
Here is my last WoG Scripts version with a few bugs in a few old poorely written WoG 3.58 scripts. You can try with it.
Current igrik's version is much more improved, uses new hookes, contains changes from Era Scripts by Algor, etc.


Скачать Герои 3 Эра и всё, что с ней связано / ERA 2.46f для старых модов
Поддержать проект
17.06.2020 14:56
Find all posts by this user Quote this message in a reply
Valery Offline

Posts: 2196
Post: #4641

Why so big changes for Era 2 ONLY last version? Why not take such important and compatibility break decisions for Era 3 only?

Ok, installed wog scripts. Is there anything to be aware of? Just install them, nothing to check in wog options etc?

Also, maybe ship 2.9.15 with wog scripts in, so no additional actions required?
(This post was last modified: 17.06.2020 15:09 by Valery.)
17.06.2020 14:59
Find all posts by this user Quote this message in a reply
igrik Offline
Administrators

Posts: 2814
Post: #4642

Berserker, на самом деле - ДА - тут я поддерживаю Валерия. Мне кажется - было сделано поспешное разделение базы Вога от скриптовой части. Я до сих пор считаю, что ветка ERA II должна нести в себе скриптовый мод как она это делала изначально. Руссификатор так же. Я так же как и Валерий выступаю за то, чтобы сделать всего 2 инсталятора ERA 2.9.15 (английский и русский) с полным функционалом и скриптовой частью.

А все радиакльные нововведения вводить в ERA III. И тут пусть скриптовая часть будет идти отдельным модом (благо для этого уже всё готово и вполне себе функционирует) и будет и дальше временно закреплена за мной.


game bug fixes extended.dll || My Plugins || My GitHub
17.06.2020 18:57
Visit this user's website Find all posts by this user Quote this message in a reply
Algor Away
Administrators

Posts: 3881
Post: #4643

Valery, igrik, не согласен.
Платформа - это платформа, ядро. Основа для модов. А затачивать свои моды или сборку на совместимость с уже включенными в ядро - тот еще кайф.
Разделение было верным шагом и не думаю, что поспешным.


BattleHeroes Rus/Eng | ERA scripts (+ReMagic) Rus/Eng
17.06.2020 22:23
Visit this user's website Find all posts by this user Quote this message in a reply
Valery Offline

Posts: 2196
Post: #4644

More than half of Era 2 mods authors are gone and inactive. If you break compatibility, is like throwing all their work as garbage. Sagamosa, Jim Vogan and so many custom maps, that's part of Era history and success.

As for me, I will not update my scripts, 10 years of work was enough. If Era 2 is no longer compatible and no wish to keep it compatible, thats fine, I shut down my google drive, remove mods from maps4heroes and thats it, move to something else.

Personally I don't see why Era 2 and Era 3 can't be separated, one for legacy, the next for progress. But tell me now what the intentions are, so I don't waste my time answering angry players emails that this or that mod no longer work.
17.06.2020 22:36
Find all posts by this user Quote this message in a reply
Bes Offline

Posts: 5422
Post: #4645

Algor, +1
P.S. просто всё упирается в многолетнее понимание WoG, когда он всегда был самодостаточным. А сейчас его раскололи на отдельные части, согласно принятой автором платформы файловой концепции, но "низы" пока это не осознали как преимущество.
единственная проблема - недостаточная информированность рядовых моддеров/фанатов в структурных изменениях (лога истории ERA как видишь, Berserker, оказывается недостаточным... нужна активная пропаганда на HC этих изменений)
17.06.2020 23:25
Visit this user's website Find all posts by this user Quote this message in a reply
Bes Offline

Posts: 5422
Post: #4646

Valery, понимаю твоё негодование, особенно когда такая армия фанатов ругается на баги при игре в твои рабочие моды.
Не стоит рубить с плеча, имхо, достаточно указать требования к работоспособности модов. Если игрок их не соблюдает - это НЕ ТВОЯ проблема, а его. Пусть ищет ответы на форуме.

P.S. и да, поднятие требований работоспособности твоих модов до обязательной установки их на платформу ERA2.9.x является сугубо твоей прерогативой. А это конечно требует определённых затрат сил, дабы всё адаптировать. Опять же, тебе решать надо тебе это или нет.
(This post was last modified: 17.06.2020 23:34 by Bes.)
17.06.2020 23:31
Visit this user's website Find all posts by this user Quote this message in a reply
Berserker Offline
Administrators

Posts: 16528
Post: #4647

igrik, я пропал на два года и скрипты 3.58 остались старыми и забагованными? Ни в коем случае нельзя на одном человеке замыкать абсолютно не связанные друг с другом задачи.

Valery, emotions are not our allies, my friend. Let me explain my position, because nothing crucial happened at all.

1) ERA ≠ Era installer package. Package is subject to changes. Everyone can make his/her own package. For instance, I installed huge 20 GB package of Skyrim with tons of mods preinstalled. They are not compatible with many other mods like your new mod, but I don't care, because absolute compatibility is not possible at all. I play mister X's package. Package is not the same as script engine of specific version, system libraries, etc. This is key point. One author can make changes in script engine, but other things are subject to change/recombine/customize.

2) If your mod depends on WoG 3.58f scripts, you either require WoG 3.58 or old Era package with 3.58 scripts frozen.
Thus, if ERA 2.46 satisfied all your needs and is well tested/has known bugs, it's ok. Specify it's as a requirement. Provide your own stable link to it. You can even modify package in WinRar and call it Heroes 3 Valery's Edition.
Create FAQ topic with the first answer: download and use this package (LINK) to play the mods. That's all.

There is no single holy link, which everyone uses. I will host 2.46 version without a problem and recommend you to do the same.
to some version, which allow to play any old/new/changed scripts/mods/packages.
And you know, igrik/Algor changed a lot in 3.58 scripts, thus my old Phoenix Mod may have issues with it. Changed scripts use new syntax/commands. I cannot just include their files with hundreds of edits and say: "They work the same as old 3.58 scripts". Even more, after some bugs were fixed (like possibility to reuse Emerald tower each month), we've got aggressive demands to restore old behavior! Some people used to play with bugs and consider them a feature! It's not a task for me to handle all of this. So let player install core and installs those scripts/mods like WoG Revised, that he wants.

Let modder write about his dependencies or specify link to package to be used.

I hope to port all your mods some day (carefully downloaded all of them) and provide possible semi-automatical translation, because they were written in English without json file usage and separate translation without code editing is hard.


Скачать Герои 3 Эра и всё, что с ней связано / ERA 2.46f для старых модов
Поддержать проект
17.06.2020 23:45
Find all posts by this user Quote this message in a reply
Bes Offline

Posts: 5422
Post: #4648

Berserker, единственным правильным для тебя ходом, в сегодняшних движениях era2/3 это размещать вместе с сылкой на релиз ещё и ссылку на WoG Scripts
дабы люди сразу качали два архива, а не упирались в ошибки и искали их причину где-то в сети
думаю это будет практично и просто
17.06.2020 23:52
Visit this user's website Find all posts by this user Quote this message in a reply
Valery Offline

Posts: 2196
Post: #4649

I still don't get why you don't let 2.9.15 with wog scripts in, so it provides 100% compatibility with all Era 2 mods, without exception. The only few actions to make everything perfect will be me removing era hooker and pandora api from my packages. Then all mods will be compatible with Era 2.

Then comes Era 3, another thing. I understand platforms evolve and I have no argument against. This is why its called Era 3 and not 2. So let me know your decision, so I can take mine.
18.06.2020 00:03
Find all posts by this user Quote this message in a reply
Bes Offline

Posts: 5422
Post: #4650

Valery, была тактическая ошибка Berserker'а, когда он после ERA2,46 не сменил глвный индекс версии... отсуюда и все эти коллизии.
Всё что после 2,46 уже другая платформа.
от 2,47/2,55 до 2,9,15 - это должна была быть ERA3.0.хх
а нынешняя ERA3 - это должна была быть ERA3.5.x
Dry
но решения назад не вернуть, так что имеем вот такие противоречия понимания одних о изменениях в концепции и автора
18.06.2020 00:14
Visit this user's website Find all posts by this user Quote this message in a reply
« Next Oldest | Next Newest »
Post Reply 


Forum Jump:

Powered by MyBB Copyright © 2002-2024 MyBB Group